[Ruby on Rails 5] Rails v5.1 に Bootstrap v4 を導入する

gem が変わっていました。

Installation

gem を追加します。
jquery に依存しているそう。

Gemfile
gem 'bootstrap', '~> 4.0.0.beta'
gem 'jquery-rails'

bundle install を実行します。

Configuration

下記の設定完了後、サーバを再起動します。

application.scss

application.scss がなければ作成します。

% mv app/assets/stylesheets/application.css app/assets/stylesheets/application.scss

*= require_tree .*= require_self は削除します。
@import します。

app/assets/stylesheets/application.scss
@import "bootstrap";

application.js

jquery と bootstrap を require します。

app/assets/javascripts/application.js
//= require jquery3
//= require popper
//= require bootstrap-sprockets